Cloud Service Partner Service Degradation

Incident Report for Stord

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 18:20 EDT

Monitoring

As our cloud service partner is mitigating errors with their platform's services, OMS and WMS are stabilizing and returning to normal operation. We will continue to monitor and post updates.
Posted Jun 12, 2025 - 15:10 EDT

Investigating

We are currently investigating and mitigating connectivity errors with our 3rd party cloud service partner.
Posted Jun 12, 2025 - 14:33 EDT
This incident affected: Stord OMS (Orders, Inventory, Insights, System Connectivity), Stord WMS (Orders, Inventory), and Cloud Service Providers.