Network-wide issues with UPS
Incident Report for Stord
Resolved
UPS has triaged and resolved their outstanding issues.
The Stord UPS account is printing labels as expected and all buildings are operational.
Posted Oct 26, 2022 - 14:18 EDT
Investigating
We are aware of ongoing, network-wide issues with UPS; please expect a delay in order processing and shipping for orders shipping via UPS. We will provide updates as we work with UPS.

Please reach out to your Customer Success Manager with any questions.
Posted Oct 26, 2022 - 10:23 EDT
This incident affected: Stord One Commerce (Orders, System Connectivity).