Delay for some customers due to vendor outage
Incident Report for Stord
Resolved
The Stord team has been monitoring the external services for the last two hours and appears to be running normally. The team has already rectified any major inconsistencies and will continue to monitor. If there is further action required, customers may be contacted directly.
Posted Sep 28, 2022 - 19:25 EDT
Update
The AWS team has given the all-clear for the incident as of 2:05pm Pacific, and our integration vendor has indicated that services are back running as normal. The Stord team will be executing its outage recovery playbook to ensure that all affected orders and fulfillments are properly processed; however, the integration vendor has indicated it may be 24-48 hours before the backlog may be processed in its entirety. An update will be provided once the recovery protocol has been completed.

Earlier today it was reported that Amazon Web Services was experiencing degraded performance in services in its us-west-2 region. One of Stord's integration vendors utilizes AWS, so Stord's connection to that vendor had been exhibiting degraded performance as well. As a result of this, some of Stord's customers may have experienced delays in being able to view new orders in Stord One Commerce and seeing fulfillments posted back to their storefront.
Posted Sep 28, 2022 - 17:09 EDT
Update
The Stord team continues to actively monitor the issue, and the latest update from AWS at 1:22PM Pacific time indicates a reduction in errors due to additional mitigations put in place, with more mitigations being applied over the next half hour. The Stord team has seen a brief improvement in performance, but has not yet fully recovered.

Earlier today it was reported that Amazon Web Services was experiencing degraded performance in services in its us-west-2 region. One of Stord's integration vendors utilizes AWS, so Stord's connection to that vendor has been exhibiting degraded performance as well. As a result of this, some of Stord's customers may be experiencing delays in being able to view new orders in Stord One Commerce and seeing fulfillments posted back to their storefront.
Posted Sep 28, 2022 - 16:45 EDT
Update
The Stord team continues to actively monitor the issue, and the latest update from AWS at 12:26PM Pacific time indicates identification of the root cause and continued on-going work to resolve, with hopeful resolution within two hours (2:30PM Pacific).

Earlier today it was reported that Amazon Web Services was experiencing degraded performance in services in its us-west-2 region. One of Stord's integration vendors utilizes AWS, so Stord's connection to that vendor has been exhibiting degraded performance as well. As a result of this, some of Stord's customers may be experiencing delays in being able to view new orders in Stord One Commerce and seeing fulfillments posted back to their storefront.
Posted Sep 28, 2022 - 15:36 EDT
Monitoring
Earlier today it was reported that Amazon Web Services was experiencing degraded performance in services in its us-west-2 region. One of Stord's integration vendors utilizes AWS, so Stord's connection to that vendor has been exhibiting degraded performance as well. As a result of this, some of Stord's customers may be experiencing delays in being able to view new orders in Stord One Commerce and seeing fulfillments posted back to their storefront. The Stord team continues to actively monitor the issue, and the latest update from AWS at 11:33AM Pacific time indicates identification of the root cause and continued on-going work to resolve.
Posted Sep 28, 2022 - 14:58 EDT
Update
Some service calls to the external vendor are starting to succeed. The Stord team is continuing to monitor.
Posted Sep 28, 2022 - 14:11 EDT
Identified
One of Stord's integration vendors has identified an outage in their Amazon Web Services components. As a result of this, customers that are integrated through this vendor may observe delays in orders and fulfillment notifications.

No workarounds are available at this time. The Stord team is actively monitoring the situation and will be ready to assess any further impact once the vendor's services have been fully restored. This page will be updated once more information is available, but as of 2:10pm Eastern AWS is currently not able to provide an ETA as of their 10:59am Pacific update.
Posted Sep 28, 2022 - 13:50 EDT
This incident affected: Cloud Service Providers and Stord One Commerce (System Connectivity).