Login to the application is blocked.

Incident Report for Stord

Resolved

This incident has been resolved.
Posted Jun 23, 2021 - 12:21 EDT

Identified

We have identified the issue and are resolving it now.
Posted Jun 23, 2021 - 12:20 EDT

Investigating

We are addressing this right now and it will be fixed in 5 minutes or less.
Posted Jun 23, 2021 - 12:18 EDT
This incident affected: Cloud Service Providers.