Address Validation Errors in Order Validation

Incident Report for Stord

Resolved

While our primary address validation partner is still returning intermittent errors, those errors are no longer degrading the performance of the OMS. We will continue to monitor order processing.
Posted Oct 20, 2025 - 20:06 EDT

Monitoring

We have deployed the enhancement to address validation and are now monitoring the system.
Posted Oct 20, 2025 - 19:58 EDT

Identified

Our address validation provider has been impacted by the AWS US-East-1 outage, and so address validation on orders is failing intermittently. We are working on an enhancement to the orders-service that will bypass a failure from our main provider and use Google as a backup provider.
Posted Oct 20, 2025 - 19:19 EDT
This incident affected: Stord OMS (Orders).