Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 29, 2025 - 05:30 EDT
Update
The maintenance, originally planned for June 22nd at 5:30 AM ET, will now take place on June 29th at 5:30 AM ET. During pre-maintenance checks, we noticed inconsistencies . The data replication to resolve the issue is going more slowly than anticipated and to ensure a successful transition we are going to move to the fallback date.
Posted Jun 21, 2025 - 11:36 EDT
Scheduled
Start: 2025-06-29 @ 0530 ET / 2025-06-29 1130 UTC End: 2025-06-29 @ 0600 ET / 2025-06-29 1200 UTC
During the above window, Stord's Site Reliability Engineering (SRE) team will be performing a planned maintenance to our core infrastructure platform. Customer's should expect delays or failures with event processing during the maintenance period. Once the maintenance is complete, impacted systems and services will return to normal operation.
Posted Jun 13, 2025 - 15:04 EDT
This scheduled maintenance affected: Stord OMS (Orders, Inventory, Insights, System Connectivity) and Stord WMS (Orders, Inventory).